Настройки — различия между версиями

Материал из Integra-S Wiki
Перейти к: навигация, поиск
Строка 1: Строка 1:
 +
====== Настройки. ======
 
В этом окне меняются/настраиваются параметры работы IPE. Все настройки делятся на категории.
 
В этом окне меняются/настраиваются параметры работы IPE. Все настройки делятся на категории.
  
 +
===== Вкладка «Общие». =====
 +
{{ :руководство_пользователя:файл:obchee.png?nolink |Общий вид вкладки настроек «Общие».}}
 +
**Инвертировать кнопки мыши —** меняет местами функционал, привязанный к левой и правой кнопки мыши.\\
 +
**Спрашивать подтверждение при выходе —** выводит на экран сообщение, с подтверждением выхода из программной среды.\\
 +
**Удаленное управление —** по умолчанию удаленное подключение к программе «Интегра планета Земля» запрещено. Его можно включить, установив данный чекбокс «разрешить», и указав необходимый номер порта. По умолчанию используется порт 1315. Опция может применяться при совместном использовании ПО «Интегра планета Земля» и стороннего ПО, для возможности доступа стороннего ПО к функциональным возможностям ПО «Интегра планета Земля» (подробное описание данного функционала см. ниже в пункте «Удаленное подключение к программе «Интегра планета Земля»).\\
 +
**Показывать здания и сооружения —** данная функция позволяет отобразить/скрыть строения (так называемые «автоздания») с карты, «автоздания» являются стандартными объектами карты, имеют привязку к расположению и подгружаются из базы «integraplanetearth».\\
 +
**Показывать надписи над зданиями и сооружениями —** активация данной функции отображает название над зданиями, название можно задать в редакторе информации зданий.\\
 +
**Использовать стандартную модель —** при установленном флажке, работают параметры «Дальность отрисовки модели» и «Шаг повторного запроса зданий». Иначе трехмерные модели всегда отображаются в режиме высокого качества текстур.\\
 +
**Радиус видимости зданий с планировкой —** это  радиус (в метрах),  в пределах которого будут отрисовываться все имеющиеся на карте трехмерные модели,  за границами указанного радиуса  модели отрисовываться уже не будут.\\
 +
**Шаг повторного запроса зданий —** параметр, определяющий повторный запрос к базе данных для загрузки моделей при перемещении карты. Чем меньше данная величина, тем чаще при перемещении подложки будет происходить запрос на загрузку на данной территории моделей.\\
 +
**Дальность отрисовки модели —** дальность (в метрах), в пределах которой модель отображается с высоким качеством текстур, при превышении заданной дальности, модель отображается с пониженным качеством текстур (tiny модель). Если параметр **«Использовать стандартную модель»** включен, то при отсутствии модели с пониженным качеством текстур, она заменяется стандартной моделью вида:\\
 +
**Цветовая схема —** состоит из 2-х цветовых наборов интерфейса светлого и темного.\\
 +
**Размер шрифта —** настройка изменяющая размер шрифта у интерфейса планеты.\\
 +
**Язык —** изменяет язык интерфейса.\\
 +
**Поисковые системы —** в роли поисковых систем выступают Nominatim и «Геокибернетика» настройка данных параметров предоставляет доступ к поиску по адресам.
  
−
== Вкладка «Общие». ==
+
===== Вкладка «Профили». =====
 +
{{ :руководство_пользователя:файл:profili.png?nolink |Общий вид вкладки «Профили».}}
 +
Когда чекбокс  «Активировать профиль мышью» установлен, то при наведении курсора мышки на здание,  все профили будут выделяться цветом, заданным в параметре «Цвет подсветки» и открываться по двойному щелчку левой кнопки мыши.
 +
Задержка перед подсветкой, это значение в секундах, которое регулирует то, как быстро активируется подсветка профиля при наведении курсора на здание, в активном поле программы.
 +
Активировав «Предактивация профилей»  то при наведении указателя мыши на изображение профиля в окне «Профили»  на плане у здания будет скрываться часть, указанная в данном профиле.
  
 +
===== Вкладка «Графика». =====
 +
{{ :руководство_пользователя:файл:grafon.png?nolink |Общий вид вкладки «Графика».}}
 +
Необходимо для настройки графики. Из настроек доступно ограничение максимального количества кадров, сглаживание и включение/выключение глобального освещения. Выбор качества полноэкранного сглаживания, увеличивает сглаживание у текстуры модели, они становятся более «гладкими», однако возрастает нагрузка на графический процессор.
  
−
[[Файл:obchee.png|центр|1000px|]]
+
===== Вкладка «Кластеризация». =====
 +
Кластеризация позволяет группировать объекты, расположенные на определенном расстоянии друг от друга.
 +
{{ :руководство_пользователя:файл:klaster.png?nolink |Общий вид вкладки «Кластеризация».}}
 +
  * Для включения кластеризации необходимо установить чекбокс «Включить кластеризацию».
 +
  * Максимальный зум – уровень зума, при достижении которого дальнейшая кластеризация не производится.
 +
  * Максимальная высота (км) – уровень высоты точки обзора, привязываемый к минимальному уровню зума (по умолчанию минимальный уровень зума 1).
 +
  * Минимальная высота (м) – уровень высоты точки обзора, привязываемый к максимальному уровню зума (по умолчанию максимальный уровень зума 20).
 +
  * Сдвиг уровня масштаба – изменение минимального и максимального уровней зума, например значение «5» будет означать, что уровень зума изменяется от 5 до 25.
 +
  * Коэффициент  кластеризации – коэффициент, определяющий объединение объектов в группу (кластер) в зависимости от уровня зума (высоты точки обзора).
 +
{{ :руководство_пользователя:файл:max_klaster.png?nolink |Максимальная высота отображения кластеризации.}}
 +
При приближении уровень зума меняется (2, 3 и далее до 20), при этом на каждом уровне происходит деление имеющихся частей карты еще на 2, т.е. на уровне зума 2  - карта делится на 4 части, на уровне зума 3 - на 8 частей и т.д. Все объекты попадающие в соответствующую часть карты, кластеризируются. На рисунках ниже показана работа механизма кластеризации при приближении карты (увеличении зума).
 +
{{ :руководство_пользователя:файл:norm_klaster.png?nolink |Изменение масштаба, разбитие кластеров на части.}}
  
−
'''Инвертировать кнопки мыши''' — меняет местами функционал, привязанный к левой и правой кнопки мыши.
+
===== Вкладка «Кэш». =====
−
Спрашивать подтверждение при выходе — выводит на экран сообщение, с подтверждением выхода из программной среды.
+
{{ :руководство_пользователя:файл:kesh.png?nolink |Общий вид вкладки «Кэш».}}
−
Удаленное управление — по умолчанию удаленное подключение к программе «Интегра планета Земля» запрещено. Его можно включить, установив данный чекбокс «разрешить», и указав необходимый номер порта. По умолчанию используется порт 1315. Опция может применяться при совместном использовании ПО «Интегра планета Земля» и стороннего ПО, для возможности доступа стороннего ПО к функциональным возможностям ПО «Интегра планета Земля» (подробное описание данного функционала см. ниже в пункте «Удаленное подключение к программе «Интегра планета Земля»).
+
На вкладке «Кэш» задаются параметры хранения кэша, а так же параметры загрузки и кеширования тайлов (фрагментов) карты.
−
Показывать здания и сооружения — данная функция позволяет отобразить/скрыть строения (так называемые «автоздания») с карты, «автоздания» являются стандартными объектами карты, имеют привязку к расположению и подгружаются из базы «integraplanetearth».
+
**«Хранить кэш» -** выберите необходимое место хранения кэша, в том числе указав нужный диск и папку. По умолчанию кэш хранится в папке C:\Integra-S\IntegaPlanetEarthCache.\\
−
Показывать надписи над зданиями и сооружениями — активация данной функции отображает название над зданиями, название можно задать в редакторе информации зданий.
+
В разделе **«Параметры кэширования тайлов карты»** предлагается четыре варианта кэширования (сверху – вниз).\\
−
Использовать стандартную модель — при установленном флажке, работают параметры «Дальность отрисовки модели» и «Шаг повторного запроса зданий». Иначе трехмерные модели всегда отображаются в режиме высокого качества текстур.
+
**Первый вариант кэширования**  подразумевает загрузку данных кэша путем соединения с ГИС – сервером  и использование загруженных данных программой (вариант по-умолчанию).\\
−
Радиус видимости зданий с планировкой — это радиус (в метрах), в пределах которого будут отрисовываться все имеющиеся на карте трехмерные модели, за границами указанного радиуса модели отрисовываться уже не будут.
+
**Второй вариант кэширования** подразумевает использование данных из кэша, без подключения к ГИС – серверу. Используется в том случае, если связь с сервером ГИС установить невозможно, а данные записываются в кэш вручную.\\
−
Шаг повторного запроса зданий — параметр, определяющий повторный запрос к базе данных для загрузки моделей при перемещении карты. Чем меньше данная величина, тем чаще при перемещении подложки будет происходить запрос на загрузку на данной территории моделей.
+
**Третий вариант кэширования** подразумевает использование данных из кэша, без перезаписи данными полученными с сервера ГИС. Используется в том случае, если есть связь с ГИС – сервером, но не нужно обновлять данные.\\
−
Дальность отрисовки модели — дальность (в метрах), в пределах которой модель отображается с высоким качеством текстур, при превышении заданной дальности, модель отображается с пониженным качеством текстур (tiny модель). Если параметр «Использовать стандартную модель» включен, то при отсутствии модели с пониженным качеством текстур, она заменяется стандартной моделью вида:
+
**Четвертый вариант кэширования** подразумевает работу программы без использования кэша, но с получением данных с ГИС – сервера. Используется в том случае если, есть связь с сервером обновлений, но кэш не нужен для работы.\\
−
Цветовая схема — состоит из 2-х цветовых наборов интерфейса светлого и темного.
+
**«Число параллельных загрузок» -** параметр, задающий возможность загрузки с ftp-сервера нескольких 3D планов одновременно. По умолчанию установлен параметр «1» - одновременно может загружаться только один план.
−
Размер шрифта — настройка изменяющая размер шрифта у интерфейса планеты.
 
−
Язык — изменяет язык интерфейса.
 
−
Поисковые системы — в роли поисковых систем выступают Nominatim и «Геокибернетика» настройка данных параметров предоставляет доступ к поиску по адресам.
 
  
−
Вкладка «Профили».
+
===== Вкладка «Слои». =====
 +
Данная вкладка содержит список всех доступных слоев (карт), параметры их загрузки и отображения. При нажатии левой кнопкой мыши по названию слоя, откроются его параметры: название слоя, тип слоя, тип драйвера, адрес слоя.
 +
{{ :руководство_пользователя:файл:sloi.png?nolink |Общий вид вкладки «Слои».}}
 +
  * Параметр «Тип слоя» указывает на принадлежность слоя определенному типу;
 +
  * Параметр «Тип драйвера» предполагает 2 типа драйвера на выбор: 
 +
    * Геоснимки;
 +
    * Рельеф.
 +
  * «Название слоя» - имя указанное при создании, возможно задать новое;
 +
  * «Минимальный зум», «максимальный зум» - границы удаления и приближения к карте, при которых отображается данный слой;
 +
  * Параметр «Видимость» означает, что этот слой подгружается в программе и виден на карте с планами, в противном случае данный слой не отображается в программе;
 +
  * Прозрачность - задает прозрачность данному слою;
 +
  * Адрес — указывает месторасположение откуда загружается слой;
 +
  * Формат тайла — указывает графический формат тайла (JPG, PNG, TIFF)
 +
  * Инвертировать координаты — функция которая меняет местами Х и У в координатах.
 +
  * Профиль — формат географической сетки EPSG:4326, EPSG:3857.
 +
Внизу слева (указано на рисунке ниже) расположена панель с функциональными кнопками:
 +
{{ :руководство_пользователя:файл:sloi1.png?nolink |}}
 +
  * Добавить слой;
 +
  * Копировать слой;
 +
  * Редактировать слой;
 +
  * Удалить слой;
 +
  * Сохранить слой;
 +
  * Редактировать слой.
 +
Для добавления и удаления слоя используйте соответствующие кнопки: «Добавить слой», «Удалить слой». При добавлении слоя открывается окно, в котором следует задать параметры типа драйвера устройства и указать тип слоя, после нажать кнопку «применить».
 +
{{ :руководство_пользователя:файл:sloi2.png?nolink |Настройка драйвера отображения слоя.}}
 +
Слои со всеми настройками могут быть экспортированы в файл и импортированы из файла, для этого используются одноименные кнопки.
 +
Рекомендуется установить как видимые следующие слои карты: NASA Blue Marble, Open Street Map, OSM Границы и дороги, Рельеф. У остальных слоев параметр «Видимый слой» можно отключить.
  
−
Общий вид вкладки «Профили». Когда чекбокс «Активировать профиль мышью» установлен, то при наведении курсора мышки на здание, все профили будут выделяться цветом, заданным в параметре «Цвет подсветки» и открываться по двойному щелчку левой кнопки мыши. Задержка перед подсветкой, это значение в секундах, которое регулирует то, как быстро активируется подсветка профиля при наведении курсора на здание, в активном поле программы. Активировав «Предактивация профилей» то при наведении указателя мыши на изображение профиля в окне «Профили» на плане у здания будет скрываться часть, указанная в данном профиле.
+
===== Вкладка «Веб». =====
 +
На вкладке «Web приложения» задаются параметры подключения для встроенных в программы «Интегра планета Земля» web компонентов.
 +
{{ :руководство_пользователя:файл:web.png?nolink |Общий вид вкладки «Веб».}}
 +
На данной вкладке нужно указать адрес для мониторинга объектов интеграции и объектов трекинга (при необходимости). По умолчанию адрес для мониторинга объектов интеграции задается в таком виде:
 +
  ws://127.0.0.1:8089/ws
 +
Это пример строки, где указывается ip адрес компьютера, где запущен сервер приложения FireFly и порт wamp.\\
 +
Также здесь прописывается адрес сервера инцидентов и задач. Используя «Универсальные вкладки» можно добавить дополнительные кнопки в основное окно программы для быстрого доступа к необходимым веб ресурсам.\\
 +
Ниже представлена адресная строка интерфейса «СКАДА», задние адреса, дает возможность активировать инструмент СКАДА, позволяющий размещать и редактировать датчики в базе интеграции. Функционал будет доступен в интерфейсе программы по нажатию на //Инструменты=>Редактор СКАДА.//
  
−
Вкладка «Графика».
+
===== Вкладка «Плагины». =====
−
 
+
Данная вкладка отображает используемые плагины, выбрав интересующий плагин в списке слева, справа отобразится информация о плагине, в нижней части находится чекбокс «Включить плагин».
−
Общий вид вкладки «Графика». Необходимо для настройки графики. Из настроек доступно ограничение максимального количества кадров, сглаживание и включение/выключение глобального освещения. Выбор качества полноэкранного сглаживания, увеличивает сглаживание у текстуры модели, они становятся более «гладкими», однако возрастает нагрузка на графический процессор.
+
{{ :руководство_пользователя:файл:plagini.png?nolink |Общий вид вкладки «Плагины».}}
−
 
 
−
Вкладка «Кластеризация».
 
−
 
 
−
Кластеризация позволяет группировать объекты, расположенные на определенном расстоянии друг от друга. Общий вид вкладки «Кластеризация».
 
−
Для включения кластеризации необходимо установить чекбокс «Включить кластеризацию».
 
−
Максимальный зум – уровень зума, при достижении которого дальнейшая кластеризация не производится.
 
−
Максимальная высота (км) – уровень высоты точки обзора, привязываемый к минимальному уровню зума (по умолчанию минимальный уровень зума 1).
 
−
Минимальная высота (м) – уровень высоты точки обзора, привязываемый к максимальному уровню зума (по умолчанию максимальный уровень зума 20).
 
−
Сдвиг уровня масштаба – изменение минимального и максимального уровней зума, например значение «5» будет означать, что уровень зума изменяется от 5 до 25.
 
−
Коэффициент кластеризации – коэффициент, определяющий объединение объектов в группу (кластер) в зависимости от уровня зума (высоты точки обзора).
 
−
Максимальная высота отображения кластеризации. При приближении уровень зума меняется (2, 3 и далее до 20), при этом на каждом уровне происходит деление имеющихся частей карты еще на 2, т.е. на уровне зума 2 - карта делится на 4 части, на уровне зума 3 - на 8 частей и т.д. Все объекты попадающие в соответствующую часть карты, кластеризируются. На рисунках ниже показана работа механизма кластеризации при приближении карты (увеличении зума). Изменение масштаба, разбитие кластеров на части.
 
−
Вкладка «Кэш».
 
−
 
 
−
Общий вид вкладки «Кэш». На вкладке «Кэш» задаются параметры хранения кэша, а так же параметры загрузки и кеширования тайлов (фрагментов) карты. «Хранить кэш» - выберите необходимое место хранения кэша, в том числе указав нужный диск и папку. По умолчанию кэш хранится в папке C:\Integra-S\IntegaPlanetEarthCache.
 
−
В разделе «Параметры кэширования тайлов карты» предлагается четыре варианта кэширования (сверху – вниз).
 
−
Первый вариант кэширования подразумевает загрузку данных кэша путем соединения с ГИС – сервером и использование загруженных данных программой (вариант по-умолчанию).
 
−
Второй вариант кэширования подразумевает использование данных из кэша, без подключения к ГИС – серверу. Используется в том случае, если связь с сервером ГИС установить невозможно, а данные записываются в кэш вручную.
 
−
Третий вариант кэширования подразумевает использование данных из кэша, без перезаписи данными полученными с сервера ГИС. Используется в том случае, если есть связь с ГИС – сервером, но не нужно обновлять данные.
 
−
Четвертый вариант кэширования подразумевает работу программы без использования кэша, но с получением данных с ГИС – сервера. Используется в том случае если, есть связь с сервером обновлений, но кэш не нужен для работы.
 
−
«Число параллельных загрузок» - параметр, задающий возможность загрузки с ftp-сервера нескольких 3D планов одновременно. По умолчанию установлен параметр «1» - одновременно может загружаться только один план.
 
−
 
 
−
Вкладка «Слои».
 
−
 
 
−
Данная вкладка содержит список всех доступных слоев (карт), параметры их загрузки и отображения. При нажатии левой кнопкой мыши по названию слоя, откроются его параметры: название слоя, тип слоя, тип драйвера, адрес слоя. Общий вид вкладки «Слои».
 
−
Параметр «Тип слоя» указывает на принадлежность слоя определенному типу;
 
−
Параметр «Тип драйвера» предполагает 2 типа драйвера на выбор:
 
−
Геоснимки;
 
−
Рельеф.
 
−
«Название слоя» - имя указанное при создании, возможно задать новое;
 
−
«Минимальный зум», «максимальный зум» - границы удаления и приближения к карте, при которых отображается данный слой;
 
−
Параметр «Видимость» означает, что этот слой подгружается в программе и виден на карте с планами, в противном случае данный слой не отображается в программе;
 
−
Прозрачность - задает прозрачность данному слою;
 
−
Адрес — указывает месторасположение откуда загружается слой;
 
−
Формат тайла — указывает графический формат тайла (JPG, PNG, TIFF)
 
−
Инвертировать координаты — функция которая меняет местами Х и У в координатах.
 
−
Профиль — формат географической сетки EPSG:4326, EPSG:3857.
 
−
Внизу слева (указано на рисунке ниже) расположена панель с функциональными кнопками:
 
−
Добавить слой;
 
−
Копировать слой;
 
−
Редактировать слой;
 
−
Удалить слой;
 
−
Сохранить слой;
 
−
Редактировать слой.
 
−
Для добавления и удаления слоя используйте соответствующие кнопки: «Добавить слой», «Удалить слой». При добавлении слоя открывается окно, в котором следует задать параметры типа драйвера устройства и указать тип слоя, после нажать кнопку «применить». Настройка драйвера отображения слоя. Слои со всеми настройками могут быть экспортированы в файл и импортированы из файла, для этого используются одноименные кнопки. Рекомендуется установить как видимые следующие слои карты: NASA Blue Marble, Open Street Map, OSM Границы и дороги, Рельеф. У остальных слоев параметр «Видимый слой» можно отключить.
 
−
 
 
−
Вкладка «Веб».
 
−
 
 
−
На вкладке «Web приложения» задаются параметры подключения для встроенных в программы «Интегра планета Земля» web компонентов. Общий вид вкладки «Веб». На данной вкладке нужно указать адрес для мониторинга объектов интеграции и объектов трекинга (при необходимости). По умолчанию адрес для мониторинга объектов интеграции задается в таком виде:
 
−
 
 
−
ws://127.0.0.1:8089/ws
 
−
Это пример строки, где указывается ip адрес компьютера, где запущен сервер приложения FireFly и порт wamp.
 
−
Также здесь прописывается адрес сервера инцидентов и задач. Используя «Универсальные вкладки» можно добавить дополнительные кнопки в основное окно программы для быстрого доступа к необходимым веб ресурсам.
 
−
Ниже представлена адресная строка интерфейса «СКАДА», задние адреса, дает возможность активировать инструмент СКАДА, позволяющий размещать и редактировать датчики в базе интеграции. Функционал будет доступен в интерфейсе программы по нажатию на Инструменты⇒Редактор СКАДА.
 
−
 
 
−
Вкладка «Плагины».
 
−
 
 
−
Данная вкладка отображает используемые плагины, выбрав интересующий плагин в списке слева, справа отобразится информация о плагине, в нижней части находится чекбокс «Включить плагин». Общий вид вкладки «Плагины».
 

Версия 12:17, 18 апреля 2017

Настройки.

В этом окне меняются/настраиваются параметры работы IPE. Все настройки делятся на категории.

Вкладка «Общие».

Руководство пользователя:файл:obchee.png?nolink

    • Инвертировать кнопки мыши —** меняет местами функционал, привязанный к левой и правой кнопки мыши.\\
    • Спрашивать подтверждение при выходе —** выводит на экран сообщение, с подтверждением выхода из программной среды.\\
    • Удаленное управление —** по умолчанию удаленное подключение к программе «Интегра планета Земля» запрещено. Его можно включить, установив данный чекбокс «разрешить», и указав необходимый номер порта. По умолчанию используется порт 1315. Опция может применяться при совместном использовании ПО «Интегра планета Земля» и стороннего ПО, для возможности доступа стороннего ПО к функциональным возможностям ПО «Интегра планета Земля» (подробное описание данного функционала см. ниже в пункте «Удаленное подключение к программе «Интегра планета Земля»).\\
    • Показывать здания и сооружения —** данная функция позволяет отобразить/скрыть строения (так называемые «автоздания») с карты, «автоздания» являются стандартными объектами карты, имеют привязку к расположению и подгружаются из базы «integraplanetearth».\\
    • Показывать надписи над зданиями и сооружениями —** активация данной функции отображает название над зданиями, название можно задать в редакторе информации зданий.\\
    • Использовать стандартную модель —** при установленном флажке, работают параметры «Дальность отрисовки модели» и «Шаг повторного запроса зданий». Иначе трехмерные модели всегда отображаются в режиме высокого качества текстур.\\
    • Радиус видимости зданий с планировкой —** это радиус (в метрах), в пределах которого будут отрисовываться все имеющиеся на карте трехмерные модели, за границами указанного радиуса модели отрисовываться уже не будут.\\
    • Шаг повторного запроса зданий —** параметр, определяющий повторный запрос к базе данных для загрузки моделей при перемещении карты. Чем меньше данная величина, тем чаще при перемещении подложки будет происходить запрос на загрузку на данной территории моделей.\\
    • Дальность отрисовки модели —** дальность (в метрах), в пределах которой модель отображается с высоким качеством текстур, при превышении заданной дальности, модель отображается с пониженным качеством текстур (tiny модель). Если параметр **«Использовать стандартную модель»** включен, то при отсутствии модели с пониженным качеством текстур, она заменяется стандартной моделью вида:\\
    • Цветовая схема —** состоит из 2-х цветовых наборов интерфейса светлого и темного.\\
    • Размер шрифта —** настройка изменяющая размер шрифта у интерфейса планеты.\\
    • Язык —** изменяет язык интерфейса.\\
    • Поисковые системы —** в роли поисковых систем выступают Nominatim и «Геокибернетика» настройка данных параметров предоставляет доступ к поиску по адресам.
Вкладка «Профили».

Руководство пользователя:файл:profili.png?nolink Когда чекбокс «Активировать профиль мышью» установлен, то при наведении курсора мышки на здание, все профили будут выделяться цветом, заданным в параметре «Цвет подсветки» и открываться по двойному щелчку левой кнопки мыши. Задержка перед подсветкой, это значение в секундах, которое регулирует то, как быстро активируется подсветка профиля при наведении курсора на здание, в активном поле программы. Активировав «Предактивация профилей» то при наведении указателя мыши на изображение профиля в окне «Профили» на плане у здания будет скрываться часть, указанная в данном профиле.

Вкладка «Графика».

Руководство пользователя:файл:grafon.png?nolink Необходимо для настройки графики. Из настроек доступно ограничение максимального количества кадров, сглаживание и включение/выключение глобального освещения. Выбор качества полноэкранного сглаживания, увеличивает сглаживание у текстуры модели, они становятся более «гладкими», однако возрастает нагрузка на графический процессор.

Вкладка «Кластеризация».

Кластеризация позволяет группировать объекты, расположенные на определенном расстоянии друг от друга. Руководство пользователя:файл:klaster.png?nolink

 * Для включения кластеризации необходимо установить чекбокс «Включить кластеризацию».
 * Максимальный зум – уровень зума, при достижении которого дальнейшая кластеризация не производится.
 * Максимальная высота (км) – уровень высоты точки обзора, привязываемый к минимальному уровню зума (по умолчанию минимальный уровень зума 1).
 * Минимальная высота (м) – уровень высоты точки обзора, привязываемый к максимальному уровню зума (по умолчанию максимальный уровень зума 20).
 * Сдвиг уровня масштаба – изменение минимального и максимального уровней зума, например значение «5» будет означать, что уровень зума изменяется от 5 до 25.
 * Коэффициент  кластеризации – коэффициент, определяющий объединение объектов в группу (кластер) в зависимости от уровня зума (высоты точки обзора).

Руководство пользователя:файл:max klaster.png?nolink При приближении уровень зума меняется (2, 3 и далее до 20), при этом на каждом уровне происходит деление имеющихся частей карты еще на 2, т.е. на уровне зума 2 - карта делится на 4 части, на уровне зума 3 - на 8 частей и т.д. Все объекты попадающие в соответствующую часть карты, кластеризируются. На рисунках ниже показана работа механизма кластеризации при приближении карты (увеличении зума). Руководство пользователя:файл:norm klaster.png?nolink

Вкладка «Кэш».

Руководство пользователя:файл:kesh.png?nolink На вкладке «Кэш» задаются параметры хранения кэша, а так же параметры загрузки и кеширования тайлов (фрагментов) карты.

    • «Хранить кэш» -** выберите необходимое место хранения кэша, в том числе указав нужный диск и папку. По умолчанию кэш хранится в папке C:\Integra-S\IntegaPlanetEarthCache.\\

В разделе **«Параметры кэширования тайлов карты»** предлагается четыре варианта кэширования (сверху – вниз).\\

    • Первый вариант кэширования** подразумевает загрузку данных кэша путем соединения с ГИС – сервером и использование загруженных данных программой (вариант по-умолчанию).\\
    • Второй вариант кэширования** подразумевает использование данных из кэша, без подключения к ГИС – серверу. Используется в том случае, если связь с сервером ГИС установить невозможно, а данные записываются в кэш вручную.\\
    • Третий вариант кэширования** подразумевает использование данных из кэша, без перезаписи данными полученными с сервера ГИС. Используется в том случае, если есть связь с ГИС – сервером, но не нужно обновлять данные.\\
    • Четвертый вариант кэширования** подразумевает работу программы без использования кэша, но с получением данных с ГИС – сервера. Используется в том случае если, есть связь с сервером обновлений, но кэш не нужен для работы.\\
    • «Число параллельных загрузок» -** параметр, задающий возможность загрузки с ftp-сервера нескольких 3D планов одновременно. По умолчанию установлен параметр «1» - одновременно может загружаться только один план.
Вкладка «Слои».

Данная вкладка содержит список всех доступных слоев (карт), параметры их загрузки и отображения. При нажатии левой кнопкой мыши по названию слоя, откроются его параметры: название слоя, тип слоя, тип драйвера, адрес слоя. Руководство пользователя:файл:sloi.png?nolink

 * Параметр «Тип слоя» указывает на принадлежность слоя определенному типу;
 * Параметр «Тип драйвера» предполагает 2 типа драйвера на выбор:  
    * Геоснимки;
    * Рельеф.
 * «Название слоя» - имя указанное при создании, возможно задать новое;
 * «Минимальный зум», «максимальный зум» - границы удаления и приближения к карте, при которых отображается данный слой;
 * Параметр «Видимость» означает, что этот слой подгружается в программе и виден на карте с планами, в противном случае данный слой не отображается в программе;
 * Прозрачность - задает прозрачность данному слою;
 * Адрес — указывает месторасположение откуда загружается слой;
 * Формат тайла — указывает графический формат тайла (JPG, PNG, TIFF)
 * Инвертировать координаты — функция которая меняет местами Х и У в координатах.
 * Профиль — формат географической сетки EPSG:4326, EPSG:3857.

Внизу слева (указано на рисунке ниже) расположена панель с функциональными кнопками: Руководство пользователя:файл:sloi1.png?nolink

 * Добавить слой;
 * Копировать слой;
 * Редактировать слой;
 * Удалить слой;
 * Сохранить слой;
 * Редактировать слой.

Для добавления и удаления слоя используйте соответствующие кнопки: «Добавить слой», «Удалить слой». При добавлении слоя открывается окно, в котором следует задать параметры типа драйвера устройства и указать тип слоя, после нажать кнопку «применить». Руководство пользователя:файл:sloi2.png?nolink Слои со всеми настройками могут быть экспортированы в файл и импортированы из файла, для этого используются одноименные кнопки. Рекомендуется установить как видимые следующие слои карты: NASA Blue Marble, Open Street Map, OSM Границы и дороги, Рельеф. У остальных слоев параметр «Видимый слой» можно отключить.

Вкладка «Веб».

На вкладке «Web приложения» задаются параметры подключения для встроенных в программы «Интегра планета Земля» web компонентов. Руководство пользователя:файл:web.png?nolink На данной вкладке нужно указать адрес для мониторинга объектов интеграции и объектов трекинга (при необходимости). По умолчанию адрес для мониторинга объектов интеграции задается в таком виде:

  ws://127.0.0.1:8089/ws 

Это пример строки, где указывается ip адрес компьютера, где запущен сервер приложения FireFly и порт wamp.\\ Также здесь прописывается адрес сервера инцидентов и задач. Используя «Универсальные вкладки» можно добавить дополнительные кнопки в основное окно программы для быстрого доступа к необходимым веб ресурсам.\\ Ниже представлена адресная строка интерфейса «СКАДА», задние адреса, дает возможность активировать инструмент СКАДА, позволяющий размещать и редактировать датчики в базе интеграции. Функционал будет доступен в интерфейсе программы по нажатию на //Инструменты=>Редактор СКАДА.//

Вкладка «Плагины».

Данная вкладка отображает используемые плагины, выбрав интересующий плагин в списке слева, справа отобразится информация о плагине, в нижней части находится чекбокс «Включить плагин». Руководство пользователя:файл:plagini.png?nolink